Content Fetch (REST) API calls are not returning a contentLinkDepth greater than 5
Incident Report for Agility CMS
Resolved
The API update to protect against over-fetching has been rolled-back and will be re-scheduled at a later time. We will notify all affected customers before releasing this.
Posted Jul 16, 2021 - 14:57 EDT
Update
We have identified that this affects a very small subset of customers and identified all API calls that are affected. Since this could be a breaking change we have decided to rollback this update until our customers have confirmed they have updated how they call the API.
Posted Jul 16, 2021 - 14:54 EDT
Monitoring
We have released a patch to improve the stability of our API to address some data over-fetching scenarios. If you are calling the Fetch API with a contentLinkDepth of 5 or greater, you may notice the response of the API has changed to limit the amount of data returned by the API.
Posted Jul 16, 2021 - 14:32 EDT
This incident affected: Content Fetch API (REST/GraphQL).